URUCHAMIANIE PROGRAMU

1.Po uruchomieniu programu mSzyfr po prawej stronie paska zadań, w tzw. obszarze

powiadomień (rys.1) pojawia się ikona w postaci złotej kłódki.

rys.1

2.Kliknięcie na ikonie powoduje pojawienie się menu podręcznego (rys.2), które

umożliwia korzystanie z podstawowych funkcji programu:

  • Szyfruj tekst – umożliwia zaszyfrowanie tekstu (patrz: Szyfrowanie tekstu)

  • Szyfruj plik – umożliwia zaszyfrowanie pliku (patrz: Szyfrowanie pliku)

  • Szyfruj katalog – umożliwia zaszyforwanie katalogu (patrz: Szyfrowanie

    katalogu)

  • Odszyfruj plik – umożliwia odszyforwanie wcześniej zaszyfrowanego pliku

    (patrz: Odszyfrowanie pliku)

  • Odszyfruj katalog – umożliwia odszyfrowanie wcześniej zaszyfrowanego

    katalogu (patrz: Odszyfrowanie katalogu)

  • Manager – zawiera zestawienie wszystkich zaszyfrowanych plików i katalogów,

    podstawowe informacje o nich oraz umożliwia wykonywanie różnych operacji na

    tych plikach i katalogach (patrz: Menedżer)

  • Opcje – umożliwia ustawienie domyślnego szyfru, za pomocą którego będą

    szyfrowane pliki i katalogi

  • Rejestracja programu – umożliwia zarejestrowanie programu (patrz: Rejestracja

    programu)

  • Pomoc – uruchamia system pomocy

  • Informacje o programie online – wyświetla informacje o programie

  • Zakończ – kończy pracę programu

rys.2


SZYFROWANIE TEKSTU

1.Kliknięcie w menu ikony Szyfruj tekst, powoduje otwarcie okna (rys.1), w którym

można wykonać nastepujące operacje:

  • przekształcenie tekstu za pomocą jednokierunkowej funkcji skrótu (patrz:

    informacje techniczne)

  • szyfrowanie i deszyfrowanie tekstu za pomocą szyfrów symetrycznych (patrz:

    informacje techniczne)

  • szyfrowanie i deszyfrowanie tekstu za pomocą szyfru asymetrycznego RSA

    (patrz: informacje techniczne)

rys.1

2.Aby przekształcić teks za pomocą jednokierunkowej funkcji skrótu:

  • wpisz w białym polu tekst do zaszyfrowania

  • wybierz jedną z funkcji skrótu:

    • MD5

    • SHA1

    • SHA256

    • SHA384

    • SHA512

    • RIPEMD160

  • kliknij przycisk szyfruj

3.Aby zaszyfrować teskt za pomocą szyfrów symetrycznych:

  • wpisz w białym polu tekst do zaszyfrowania

  • wybierz jeden z szyfrów symetrycznych:

    • DES

    • RC2

    • Rijndael

    • TripleDES

  • kliknij przycisk Szyfruj

  • wpisz hasło i zatwierdź przyciskiem [OK] lub [Enter]

4.Aby odszyfrować wcześniej zaszyfrowany teskt za pomocą szyfrów symetrycznych:

  • skopiuj zaszyfrowany tekst do białego pola

  • wybierz szyfr, za pomocą którego teskt został zaszyfrowany

  • kliknij przycisk Deszyfruj

  • wpisz to samo hasło, które zostało użyte do zaszyfrowania tego tekstu i

    zatwierdź przyciskiem [OK] lub [Enter]

5.Aby zaszyfrować tekst za pomocą szyfru asymetrycznego RSA:

  • wpisz w białym polu tekst do zaszyfrowania

  • wybierz szyfr RSA

  • kliknij przycisk Szyfruj

  • po pojawieniu się okna (rys.2), kliknij przycisk Wygeneruj, w celu stworzenia

    klucza publicznego i prywatnego

  • wygenerowane klucze można zapisać używając przycisków: Zapisz prywatny i

    Zapisz publiczny

  • zatwierdź przyciskiem [OK] lub [Enter]

rys.2

6.Aby odszyfrować wcześniej zaszyfrowany tekst za pomocą szyfru asymetrycznego

RSA:

  • skopiuj zaszyfrowany tekst do białego pola

  • wybierz szyfr RSA

  • kliknij przycisk Deszyfruj

  • po pojawieniu się okna (rys.2), kliknij przycisk Wczytaj, w celu znalezienia

    wcześniej zapisanego klucza prywatnego i zatwierdź przyciskiem [OK] lub

    [Enter]

7.Uwaga:

W celu szybszego przenoszenia tekstu użyj:

  • przycisku Kopiuj zaszyfrowany tekst, dla tekstów zaszyfrowanych

  • przycisku Kopiuj czysty teskt, dla tesktów do zaszyfrowania


SZYFROWANIE PLIKU

Szyfrowanie pliku może odbyć się na dwa sposoby:

1.Aby zaszyfrować plik:

  • kliknij na nim prawym klawiszem myszy i wybierz opcję Wyślij do, a następnie

    program mSzyfr

  • po ukazaniu się okna (rys.1), ustaw parametry szyfrowania, czyli:

    • pole Plik wynikowy, które wskazuje miejsce zaszyfrowanego pliku, zostaje

      automatycznie uzupełnione – jest to samo miejsce, w którym znajduje się

      wyjściowy plik; aby to zmienić, kliknij ikonę

    • podaj hasło

    • powtórz hasło

    • zatwierdź przyciskiem [OK] lub [Enter]

    • po pojawieniu się okna, wybierz czy plik źródłowy ma zostać po

      zaszyfrowaniu usunięty

rys.1

2. Aby zaszyfrować plik:

  • w menu wybierz Szyfruj plik

  • po ukazaniu się okna (rys.2) ustaw parametry szyfrowania, czyli:

    • klikając ikonę obok pola Plik do zaszyfrowania, wskaż plik, który chcesz

      zaszyfrować

    • pole Plik wynikowy, które wskazuje miejsce zaszyfrowanego pliku, zostaje

      automatycznie uzupełnione – jest to samo miejsce, w którym znajduje się

      wyjściowy plik; aby to zmienić, kliknij ikonę

    • domyślnie ustawiony algorytm można zmienić

    • podaj hasło

    • powtórz hasło

    • zatwierdź przyciskiem [OK] lub [Enter]

    • po pojawieniu się okna, wybierz czy plik źródłowy ma zostać po

      zaszyfrowaniu usunięty

rys.2

Uwagi:

Wskaźnik siły hasła wskazuje jak bezpieczne jest hasło.

Szyfrowanie pliku pierwszym sposobem odbywa się za pomocą algorytmu wcześniej

ustawionego w opcjach (patrz: Uruchamianie programu)


ODSZYFROWANIE PLIKU

Odszyfrowanie pliku może odbyć się na dwa sposoby:

1.Aby odszyfrować plik:

  • kliknij na nim dwukrotnie

  • po ukazaniu się okna (rys.1), ustaw parametry deszyfrowania, czyli:

    • pole plik Wynikowy, które wskazuje miejsce odszyfrowanego pliku, zostaje

      automatycznie uzupełnione – jest to samo miejsce, w którym znajduje się

      wyjściowy plik; aby to zmienić, kliknij ikonę

    • podaj to samo hasło,za pomocą którego plik został zaszyfrowany

    • zatwierdź przyciskiem [OK] lub [Enter]

    • po pojawieniu się okna, wybierz czy plik źródłowy ma zostać po

      odszyfrowaniu usunięty

rys.1

2.Aby odszyforwać plik:

  • w menu wybierz Odszyfruj plik

  • po ukazaniu się okna (rys.2), ustaw parametry deszyfrowania, czyli:

    • klikając ikonę obok pola Plik do odszyfrowania, wskaż plik, który chcesz

      odszyfrować

    • pole Plik wynikowy, które wskazuje miejsce odszyfrowanego pliku, zostaje

      automatycznie uzupełnione – jest to samo miejsce, w którym znajduje się

      wyjściowy plik; aby to zmienić, kliknij ikonę

    • algorytm zostaje automatycznie zmieniony na ten, którym plik był

      szyforwany

    • podaj hasło

    • zatwierdź przyciskiem [OK] lub [Enter]

    • po pojawieniu się okna, wybierz czy plik źródłowy ma zostać po

      odszyfrowaniu usunięty

rys.2


SZYFROWANIE KATALOGU

Szyfrowanie katalogu może odbyć się na dwa sposoby:

1.Aby zaszyfrować katalog:

  • kliknij na nim prawym klawiszem myszy i wybierz opcję Wyślij do, a następnie

    program mSzyfr

  • po ukazaniu się okna (rys.1), ustaw parametry szyfrowania, czyli:

    • pole Wynik, które wskazuje miejsce zaszyfrowanego katalogu, zostaje

      automatycznie uzupełnione – jest to samo miejsce, w którym znajduje się

      wyjściowy katalog; aby to zmienić, kliknij ikonę

    • podaj hasło

    • powtórz hasło

    • zatwierdź przyciskiem [OK] lub [Enter]

    • po pojawieniu się okna, wybierz czy plik źródłowy ma zostać po

      zaszyfrowaniu usunięty

rys.1

Uwaga:

Wskaźnik siły hasła wskazuje jak bezpieczne jest hasło.

2. Aby zaszyfrować katalog:

  • w menu wybierz Szyfruj katalog

  • po ukazaniu się okna (rys.2) ustaw parametry szyfrowania, czyli:

    • klikając ikonę obok pola Folder do zaszyfrowania, wskaż katalog, który

      chcesz zaszyfrować

    • pole Wynik, które wskazuje miejsce zaszyfrowanego katalogu, zostaje

      automatycznie uzupełnione – jest to samo miejsce, w którym znajduje się

      wyjściowy katalog; aby to zmienić, kliknij ikonę

    • domyślnie ustawiony algorytm można zmienić

    • podaj hasło

    • powtórz hasło

    • zatwierdź przyciskiem [OK] lub [Enter]

    • po pojawieniu się okna, wybierz czy katalog źródłowy ma zostać po

      zaszyfrowaniu usunięty

rys.2


ODSZYFROWANIE KATALOGU

Odszyfrowanie katalogu może odbyć się na dwa sposoby:

1.Aby odszyfrować katalog:

  • kliknij na nim dwukrotnie

  • po ukazaniu się okna (rys.1), ustaw parametry deszyfrowania, czyli:

    • pole Wynik, które wskazuje miejsce zaszyfrowanego katalogu, zostaje

      automatycznie uzupełnione – jest to samo miejsce, w którym znajduje się

      wyjściowy katalog; aby to zmienić, kliknij ikonę

    • podaj to samo hasło,za pomocą którego katalog został zaszyfrowany

    • zatwierdź przyciskiem [OK] lub [Enter]

    • po pojawieniu się okna, wybierz czy katalog źródłowy ma zostać po

      odszyfrowaniu usunięty

rys.1

2.Aby odszyforwać katalog:

  • w menu wybierz Odszyfruj katalog

  • po ukazaniu się okna (rys.2), ustaw parametry deszyfrowania, czyli:

    • klikając ikonę obok pola Folder do odszyfrowania, wskaż katalog, który

      chcesz odszyfrować

    • pole Wynik, które wskazuje miejsce odszyfrowanego katalogu, zostaje

      automatycznie uzupełnione – jest to samo miejsce, w którym znajduje się

      wyjściowy katalog; aby to zmienić, kliknij ikonę

    • algorytm zostaje automatycznie zmieniony na ten, którym katalog był

      szyforwany

    • podaj hasło

    • zatwierdź przyciskiem [OK] lub [Enter]

    • po pojawieniu się okna, wybierz czy plik źródłowy ma zostać po

      odszyfrowaniu usunięty

rys.2


MENEDŻER

1.Aby uruchmić Menedżera wybierz w menu Manager.

2.Menedżer (rys.1) zawiera zestawienie wszystkich zaszyfrowanych plików i

katalogów, podaje podstawowe informacje o nich tj.:

  • Plik – miejsce zaszyfrowanego pliku lub katalogu na dysku

  • Czas – data zaszyfrowania pliku lub katalogu

  • Algorytm – rodzaj algorytmu, którym zaszyfrowano plik lub katalog

  • Typ – struktura, w jakiej zawarte są dane (plik lub katalog)

  • Komputer – nazwa komputera, na którym zaszyfrowano plik lub katalog

rys.1

2.Menedżer umożliwia wykonywanie różnych operacji na zaszyfrowanych plikach lub

katalogach. Zaznaczenie jednego pliku (rys.2) powoduje podświetlenie poleceń, z

których można skorzystać:

  • Odszyfruj – umożliwia odszyfrowanie zaznaczonego pliku (patrz: Odszyfowanie

    pliku lub katalogu)

  • Szyfruj – umożliwia ponowne zaszyfrowanie zaszyfrowanego pliku lub katalogu

    (patrz: Szyforwanie pliku lub katalogu)

    Uwaga: Tylko w Menedżerze można wielokrotnie szyfrować zaszyfrowany

    wcześniej plik lub katalog. Próba zaszyfrowania wcześniej zaszyfrowanego pliku

    lub katalogu innym sposobem spowoduje rozpoczęcie procesu odszyforwania

    tego pliku lub katalogu.

  • Usuń pozycję – usuwa zaznaczoną pozycję z menedżera lub całkowicie

  • Dodaj plik – umożliwia dodanie zaszyfrowanego pliku lub katalogu do

    menedżera

  • Edytuj opis – umożliwia dodanie i edycję opisu zaszyforwanego pliku lub

    katalogu

  • Folder docelowy – wyszukuje i otwiera folder, w którym znajduje się

    zaszyforwany plik lub katalog

rys.2

3.Po kliknięciu na wybranej pozycji prawym klawiszem myszy, otwiera się menu

podręczne, które umożliwia:

  • usunięcie tej pozycji z menedżera lub całkowicie

  • dodanie lub edycję opisu

  • otwarcie folderu docelowego, w którym znajduje się zaznaczony plik lub katalog

rys.3

Uwaga:

Pasek narzędzi można umieszczać po obu stronach okna, a także u góry i na dole,

przeciągając go.

4.Skróty klawiaturowe

  • Ctrl + Del – usuwa zaznaczoną pozycję z menedżera lub całkowicie

  • Ctrl + E – dodaje i i edytuje opis do zaznaczonej pozycji

  • Ctrl + O – otwiera folder docelowy, w którym znajduje się zaznaczony plik lub

    katalog


REJESTRACJA PROGRAMU

Aby zarejestrować program:

  • wybierz w menu Rejestracja programu, a następnie Uzyskaj kod ze strony www

  • po wypełnieniu formularza, kliknij przycisk Wyślij

  • skopiuj kod rejestracyjny

  • wybierz w menu Rejestracja programu, a następnie Wprowadź dane rejestracji

  • wprowadź dane i kliknij przycisk Zastosuj


INFORMACJE TECHNICZNE

Jednokierunkowa funkcja skrótu (funkcja haszująca) – przekształcenie, które z

wiadomości o dowolnej długości generuje krótką wartość (skrót), unikalny i

charakterystyczny dla tej wiadomości. Funkcje skrótu znajdują powszechne

zastosowanie przy podpisach cyfrowych oraz sprawdzaniu poprawności pliku

przesyłanego drogą internetową. Wynik w programie mSzyfr jest zamieniany z tablicy

bajtów (wcześniej bitów) na system szesnastkowy. Wyróżniamy następujące rodzaje

funkcji haszujących:

  • MD5 – o długości hasha 128 bitów (32 znaki w systemie szesnastkowym)

    Informacje dodatkowe: http://pl.wikipedia.org/wiki/MD5

  • SHA1 – o długości hasha 160 bitów (40 znaków w systemie szesnastkowym)

    Informacje dodatkowe: http://pl.wikipedia.org/wiki/SHA-1

  • SHA256 – o długości hasha 256 bitów (64 znaków w systemie szesnastkowym)

  • SHA384 – o długości hasha 384 bity (96 znaków w systemie szesnastkowym)

  • SHA512 – o długości hasha 512 bitów (128 znaków w systemie

    szesnastkowym)

  • RIPEMD160 – o długości hasha 160 bitów (40 znaków w systemie

    szesnastkowym)

Informacje dodatkowe:

http://ipsec.pl/leksykon/hash.php

http://pl.wikipedia.org/wiki/Funkcja_skr%C3%B3tu

Szyfr symetryczny – szyfr, w którym tym samym kluczem szyfrujemy i

odszyfrowujemy dane. Wyróżniamy nastepujące rodzaje szyfrów symetrycznych:

  • DES – klasyczny szyfr symetryczny o długości klucza 64 bity

    Informacje dodatkowe: http://pl.wikipedia.org/wiki/DES

  • RC2 – szyfr o długości klucza 128 bitów

  • Rijndael (AES) – szyfr o długości klucza 256 bitów

    Informacje dodatkowe: http://pl.wikipedia.org/wiki/AES

  • TripleDES – szyfr od długości klucza 192 bity

Informacje dodatkowe:

http://ipsec.pl/leksykon/symasym.php

Szyfr asymetryczny – szyfr, w którym jednym kluczem szyfrujemy dane, a drugim

odszyfrowujemy. Klucz szyfrujący nazywa się kluczem jawnym (publicznym),

natomiast klucz odszyfrowujący kluczem tajnym (prywatnym). Przykładem szyfry

asymetrycznego jest:

  • RSA – szyfr o dowolnej długości klucza; w programie długość klucza wynosi

    1024 bity

Informacje dodatkowe: